Astuce Ubuntu 10.10 : Retrouver l’écran de boot haute résolution après l’installation des drivers nVidia

Boom ! Vous faites partie de ceux qui ont bidouillé leur grub pour avoir un écran de démarrage en haute résolution après la sortie d'Ubuntu 10.04 Lucid Lynx ? Et vous êtes désormais passé à Ubuntu 10.10 Maverick Meerkat en pensant que le problème serait résolu ?

Et bien non ! Et c'est même pire ! En effet, après l'installation des pilotes nVidia propriétaire, Lucid avait au moins la décence d'afficher le logo ubuntu en basse résolution contrairement à Maverick qui affiche un mode console avec "Ubuntu 10.10" et 4 petits points juste en-dessous du titre en guise d'écran de démarrage.

Et bien figurez vous, que l'astuce que vous aviez utilisé en Avril fonctionne encore avec Maverick. Et l'objectif est d'atteindre ceci :

Et voici les étapes à réaliser :

Etape 1 :

Ouvrez un terminal, et tapez ceci à l'intérieur :

sudo apt-get install v86d

Validez en mettant le mot de passe root et laissez l'installation se faire...

Etape 2 :

Toujours dans la même fenêtre du terminal, tapez :

sudo gedit /etc/default/grub

Et dans le fichier qui s'ouvre, remplacez :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" par GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap" (ou une autre résolution, si supporté)

ainsi que :

#GRUB_GFXMODE=640x480 par GRUB_GFXMODE=1280x1024 (ou n'importe quelle autre résolution native que vous voulez mettre si supporté)

Enregistrez et fermez le fichier

Etape 3 :

Toujours dans le terminal, tapez :

sudo gedit /etc/initramfs-tools/modules

le fichier s'ouvre et ajoutez ceci à l'intérieur :

uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap (ou une autre résolution, si supporté)

Enregistrez et fermez le fichier

Etape 4 :

Tapez ceci toujours dans le terminal :

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash

puis sudo update-grub2 et sudo update-initramfs -u

Etape 5 :

Redémarrez et admirez.

0 0 vote
Note de l'article
Subscribe
Me notifier des
guest

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

16 Commentaires
Inline Feedbacks
Voir tous les commentaires
tonkeek
9 années plus tôt

Merci !!! Je commencais à désespérer !!

KEN
KEN
9 années plus tôt

Bonjour à tous
Je viens d'essayer les étapes que tu proposes et voilà: toujours rien de changé sur mon écran.
Je signale que j'ai bien suivi les étapes...
Aidez-moi svp!
Merci

KEN
KEN
9 années plus tôt

J'ai entré 1280*1024 puis que je veux le max comme c'était avec XP.
Par contre, je ne sais comment lire ma carte graphique depuis ubuntu.
Merci pour votre aide...

(Intel Celeron T1400, 15.4" WXGA.)

Alesson
9 années plus tôt

J'ai le même problème (j'ai un écran noir pendant le boot et ensuite j'ai le logo vite fait d'ubuntu), sauf que ma carte est une ATI HD4570. Croyez-vous que je dois procéder comme vous ?

Dr Nuisible
9 années plus tôt

Merci beaucoup, ça marche !

deoxis974
9 années plus tôt

Fonctionne pour ATI tester par moi =)

sauver GRUB --> sudo cp /etc/default/grub en .bak ou vous voulais.

faire la modification dans le grub
mais changé juste la résolution dans le grub , vous remplacé par

GRUB_GFXMODE=1280x1024

Suiver la suite du TUTO
et ENJOY...

Penser a sauver vos config avant de vous lancé

--------------------------UBUNTU 10.10------------------------- It's a BEST -----------------------------

deoxis974
9 années plus tôt

ps: ne pas faire l'étape 2 , faite ce que j'ai dit avant =) REALITY <3

Conor
9 années plus tôt

Bonjour, j'ai depuis un moment déjà la version d'Ubuntu 10.10 et le splash screen de démmarage a disparu. J'ai donc suivi votre tuto. j'ai mis une résolution de 640x480 car sinon le démarrage n'est pas centré (sinon help bienvenu :D). Maintenant, au démarrage j'ai toujours un vieux Ubuntu 10.10 avec des points tandis que lorsque je ferme mon pc j'ai le tout beau !!! J'aimerai bien résoudre ce problème 🙂

Conor
9 années plus tôt

Nouvelle : j'ai corriger une donnée : j'ai remis ce qu'il faut mettre après "quiet splash" et maintenant j'ai récupérer le beau logo au démarrage mais maintenant AUTRE problème : il n'est pas centré à mon écran, il y a une grosse barre noir à droite.

HELP =)

loliverouge
9 années plus tôt

salut,

Tuto testé (avec toutes les étapes) sur une ATI "ATI Technologies Inc M96 [Mobility Radeon HD 4650]" avec Ubuntu 10.10 et driver ATI Proprio. TEST OK.

Merci 😉

lolalilo
9 années plus tôt

Salut j'

lolalilo
9 années plus tôt

re salut j'ai essayer cette technique car il s'agit exactement de mon problem, sauf que ca marche pas, j'ai d'abord essayer en 1440 900 mais au demarrage l'ecran me signal que la frequence est non supporté...
j'ai essayé aussi avec vos valeur, le splash screen semble bien fonctionner mais ensuite mon bureau s'ouvre toujours en 6401 480 ...
bref si vous pouviez m'aider ca serait cool...

FreddyONE
9 années plus tôt

1280×1024 et non
1280*1024 !

Hydrog3n
9 années plus tôt

Merci beaucoup pour cette information 😉